Monday, June 27, 2016

A couple of small epiphany's in a day in the life.

It was a bemusing and somewhat vexing problem that at first blush was all caused by a watch. It's 5ish in the afternoon on a Saturday and I'm clutching an adult beverage at a function when the phone rings. I stare at the magic box doing it's best to attract my attention. I sigh and take the call. It's a local Captain who is taking a boat way offshore on Monday and his autopilot is now kaput ostensibly caused by a Garmin Quatix watch. This is a new one to me and he now has my attention.

He launches into the saga. He has a original Quatix watch, and tried to connect it to the autopilot while underway. The autopilot immediately freaks out, and has to be put in standby to get control of the boat. The watch is disconnected from the system and he attempts to reengage to autopilot. The odd thing is now the autopilot seems fine until you engage it. Instead of doing its "Otto Pilot" thing it now pops up the "Shadow Drive" is on message and does nothing else. What this normally means is the helm has been manually turned, the autopilot thinks you want control of the boat, and gives it to you. This isn't supposed to happen when you first engage it, and I have never seen one do this. I agree to visit the boat on Sunday morning to see what can be done and will bring the latest software with me.


The boat is a new and large center console fishing boat from a good builder. It has three Garmin 7616 MFD's installed by the factory in the dash. I take a quick glance at the gear connected to it and don't see anything of concern other than older software.

The Captain shows me the problem, and what the hell. The damn thing goes straight to "Shadow Drive" when you engage it. So step one is to do a full software upgrade and see if that corrects the problem. This takes about 20 minutes to do. It's is a zen thing and I have some level of confidence all will be okay when done, but it isn't. The problem stubbornly remains. I take a closer look at the autopilot set up It seems to be okay, and the Shadow Drive is disengaged. What's up with this? I think maybe I should look at the autopilot's computer and see what the idiot LED light is saying.

I go off to the truck to get some boat disassembly tools and the first epiphany slowly seeps in. It's a funny thing about our brains. The Captain had mentioned the Shadow Drive message in his call to me. I had played with the autopilot and seen the Shadow Drive message a dozen times so I erroneously assumed it had one. I slowly realized on the walk back to the truck his boat doesn't have a shadow drive at all. It's a steer by wire system as the image of the boat's Teleflex Optimus 360 joystick appears floating in my head. Something else is going on here.

The console is opened, and yep it's a steer by wire Reactor and I had overlooked the SBW designation when I checked the N2K device list. Further it's telling me via the LED idiot light it thinks it feels okay. I scratch my head and try to figure out what to do next.

When solving a problem in a system with lots of stuff hanging on it information is important, and the Captain had some. He had done some excellent and smart problem solving before I had arrived as evidenced by all of the boat's documentation spread out on the berth.

Buried in the back of the console were two gateways. The first was for the engine interfaces, and the second was for the autopilot. Look he says "the autopilot interface LED is doing a two blink." This means in effect that it's talking to the steering system but not the the autopilot.

The second epiphany starts to coalesce. In my first conversation with the Captain he mentioned something about a Garmin GNT-10 being installed on the boat with issues. This black box transmits ANT+ from the network to devices like like a Quatix watch. The dealer had installed it on in the boat after the fact. 

According to the Captain it had been plugged directly into a N2K port on the back of one of the MFD's and didn't work. I wasn't surprised about that. The boat dealer had just recently returned and installed it on the Garmin network, or so they thought. The last of the puzzle fell into place and I now knew exactly what was wrong.

NMEA 2000 is a version of CAN bus, and uses in many cases the same deviceNet connectors. So in effect there are what appears to be two nearly identical NMEA 2000 networks in the boat. They look the same but one is CAN bus only, and the other is NMEA 2000. The two don't play nicely together at all.

So what happened was the dealer's installer added the GNT-10 to the CAN bus network, and not the NMEA network. This is what was causing the havoc with the autopilot.

So how do you tell the two networks apart? The first thing to look for is a network with only three "Tee's" in it like the drawing above shows. The second way to tell is the tag on the Reactor's cable that says "Do not connect to a NMEA 2000 bus." In this case the opposite happened and a NMEA 2000 device was plugged into a CAN bus network.

This problem should not have happened in the first place and I can only make some broad assumptions about why it happened. The reality is the installation of the GNT-10 after the fact was a waste of money because the three factory installed 7616's were already ANT+ capable.

If I was to guess both the Captain and the owner have Quatix watches and somewhere along the line an inquiry was made to the dealer if they would interface to the installed systems. Someone there made a determination that a GNT-10 was needed and arranged to have it installed, twice and incorrectly both times. I left the GNT-10 in place now unplugged but it should be removed. Sheesh, what a way to spend a Sunday morning, but the boat is fine now and well offshore today with a happy Captain as I'm writing this.

6 comments:

  1. Entertaining as always! You will need to change the tag line "A blog about the things boat builders do that cost you money" to "A blog about the things boat builders and electronics manufacturers do that cost you money"

    ReplyDelete
  2. Really interesting, Bill, but you may have missed one nuance. Apparently the ANT wireless built into the GNT-10 is different from the ANT built into newer MFDs like the 7616 (and the GNX Wind).

    As best I can tell the Quatix 3 watch (and new gWind Wireless 2 transducer) will not work with the GNT-10 and the original Quatix won't work with 76xx. I have no idea what changed in ANT but note the difference in "compatible" lists.

    ReplyDelete
    Replies
    1. Ben, you're probably right, and I wasn't aware of that. The GNT 10 had originally been plugged into the N2K port on the back of one of the MFD's. It didn't, and couldn't work. Someone then disconnected it and connected to the the Canbus network of the Reactor. The first time, in this case the original Quatix watch was used the autopilot malfunctioned. To add to the complexity the boat has both the new Quatix 3 and the original Quatix watch on board. Garmin's specs are pretty mum on the subject and they just say both are ANT+ devices. I'll have a chat with Garmin in the morn.

      Delete
    2. Bill,

      The Quatix 3 is to be paired to the 7616 and the original Quatix to the GNT-10.

      What did Garmin respond to you? Don't leave us hangin'.

      Delete
    3. Anon, as Ben point out above the original Quatix watch is much different then the new one. Although I knew the Quatix 3 was new it never occurred to me it would do in some cases less than the original.

      Delete
  3. I have a wee question or two about nmea 1835 and a wifi gadget. Can i fire them at you? Its interesting to use instruments like these but i am a bit of a dinosour and only experience with the trusted basics and find i can not see the point of too many gadget. But no experience of them is possibly the only thing letting me have a go, and budget of course, the mother of invention and making do.

    ReplyDelete